The issue is because of Cloudflare Global Network experiencing issues: https://www.cloudflarestatus.com. For critical services using our DR setup, we brought back the services. For Non critical we are monitoring status. Once they resolve it get resolved here
Posted Nov 18, 2025 - 12:00 UTC
Investigating
Note all the critical services in Kyro works fine, The notification service and icons got impacted because of Cloudflare Downtime.
Posted Nov 18, 2025 - 11:48 UTC
This incident affected: Application (Web App, Notifications).